Vimeo does not work with Firefox and the FlashBlock plugin

The problem

Recently, I noticed that Vimeo does not work anymore with the Flashblock Firefox Add-on: the play button shows up, but pressing it does not give you video during playback (even though audio works). I was using Firefox 27.0.1 under Windows 7 when I first noticed it and did not check it under Linux yet.

There are some discussions on this at the Vimeo forums, but at the moment the only solution is to disable Flashblock — on the Vimeo website only of course.

This is how you fix it:

In Firefox, go to Tools -> Add-ons. Select Extensions, then choose Flashblock on the right. Click Options and under the Whitelist tab, add vimeo.com to the list. This fixed it.

Here is a screenshot of the prodedure:##

vimeo fix

Advertisements

About dfspspirit

PhD student in bioinformatics, interested in photography, level design, digital image manipulation, architecture and, of course, bioinformatics.
This entry was posted in general, IT and computers, troubleshooting and tagged , , , . Bookmark the permalink.

3 Responses to Vimeo does not work with Firefox and the FlashBlock plugin

  1. DK says:

    I followed these steps but the video still does not work. It plays with audio, but the video screen remains black with the square “Flash” icon in the center. Any suggestions?

    • dfspspirit says:

      Hm, I just tried it and it works as described for my setup. I am using FireFox version 41.0 under Linux at this box. I can try it under Win7 later.

      What’s your FF version and O/S?

  2. Konrad says:

    You need:
    vimeo.com
    vimeocdn.com
    player.vimeo.com

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s